Bug #2793

Accounts are incorrectly marked as invalid.

Added by drbits almost 4 years ago. Updated 7 months ago.

Status:Closed Start date:12/27/2010
Priority:Normal Due date:
Assignee:jiaz % Done:

100%

Category:General
Target version:020 - Next Release 2.0
Resolution:Fixed

Description

JDownloader marks premium accounts on many hosts as invalid (either when refreshing the Accounts table or between downloads). FileServe is one of the sites for which this often happens. When enabling an account in the table, it can take several tries before the account is enabled.

The suspected cause is a communication error (such as time-out) when JD checks for the Premium status. If such an error occurs when enabling an account, the error message should appear instead of "Invalid Account". Once an account has been established as valid, when there is a problem checking the account, the assumption should be that the account is still valid. This should be kept between sessions.

The problem appears to be much worse in parts of the world with high latency.

History

Updated by jiaz almost 4 years ago

im sorry but fileserve is caused by isp/server side issue. no jd problem here.
i can only try to add workarounds.

Updated by coalado almost 2 years ago

  • Assignee set to jiaz
  • Priority changed from Urgent to Normal

Jiaz: What's up with this ticket? Please reject it if there is no problem

Updated by jiaz over 1 year ago

  • Target version changed from 010 - Next Major Public Release 1.xxx to 020 - Next Release 2.0

Updated by jiaz over 1 year ago

need logs

Updated by jiaz 7 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Resolution set to Fixed

all ioexceptions should now result in temp disabled, not in invalid

Also available in: Atom PDF