Bug #2564

Filesonic.com: There is no download limit for premium users

Added by drbits over 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:10/20/2010
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Hoster
Target version:-
Resolution:Can't reproduce

Description

Using a premium account to download several files from filesonic.com, the user reports that JD reverted to free user-like behaviour (Captcha). The user did not specify whether speed was reduced as well.

(Login PMed to pspzockerscene & drbits)

History

#1 Updated by drbits over 4 years ago

Apparently, Filesonic reversed the position of their buttons (Free or Premium) on the screen.
Everybody is getting a Plugin Error (out of date).

#2 Updated by pspzockerscene over 4 years ago

  • Assignee deleted (pspzockerscene)

#3 Updated by drbits over 4 years ago

Important Revision

When an available check is broken, it will cause a Premium Error, which in turn disables Premium for that Host. An available check should not cause a Premium Error.

A Premium Error should not disable Premium except at start-up and during Refresh Accounts.

Both of these problems are generic handling of Status, not related to a specific host. In an object oriented design, the plugins would translate requests and responses to specific hosts (including standardizing status). Decision making within Plugins would be minimized.

The Host_Plugin class should interpret the status. A "next step" should be decided (in the case of a lack of information, the information should be logged. Multiplication of problems should be avoided.

Please see http://board.jdownloader.org/showpost.php?p=112230&postcount=64
Log is linked to http://board.jdownloader.org/showpost.php?p=112181&postcount=61

#4 Updated by jiaz over 4 years ago

When an available check is broken, it will cause a Premium Error, which in turn disables Premium for that Host. An available check should not cause a Premium Error.

i cannot verify this. accounts are only disabled when plugin says so.
please provide example links AND logfiles.
jd will only disable the account when the correct pluginexception is thrown

#5 Updated by pspzockerscene about 4 years ago

Do we still have any problem here ?
I don't think so.
I'll close it if no one responds within one week...

#6 Updated by pspzockerscene about 4 years ago

  • Status changed from New to Closed
  • Resolution set to Can't reproduce

Closed, problem is (hopefully) gone, got no userfeedback...

Also available in: Atom PDF