Bug #1833

Remove "Waiting for new IP" and Fatal Error message from UI

Added by drbits almost 4 years ago. Updated 11 months ago.

Status:Rejected Start date:05/28/2010
Priority:High Due date:
Assignee:coalado % Done:

0%

Category:General
Target version:010 - Next Major Public Release 1.xxx Estimated time:2.00 hours
Resolution:Can't reproduce

Description

Messages like "Waiting for new IP" and coloring link lines because of this status are not helpful. The link is waiting its turn and that has nothing to do with the IP. There is a link in a wait with a countdown, that should be shown.

The "Waiting for new IP" makes users panic about not being able to reconnect. Since Reconnect is an advanced feature and is not always possible, this is counter productive and greatly adds to Support needs.

Any other messages that propagate to all links from a host should also be removed.


Related issues

related to Bug #1260: Locking hosts due to wait states Closed 02/08/2010

History

Updated by drbits almost 4 years ago

Depositfile is an example of a host plugin that allows each link to try to connect and then the link is assigned a wait time. This means the possibility of hundreds of timers updating frequently. When this happens, and JD is minimized with the Downloads page selected, JD can still use over 90% of my CPU time. If the LinkGrabber page is selected, JD uses less than 10% of my CPU time.

There is also a noticeable delay when all of the links for a host are changed to a Host Wait state (or that status is removed).

With the number of plugins that can act this way, it is clear that the wait process must be centralized.

Updated by coalado over 3 years ago

  • Assignee set to coalado
  • Target version changed from 040 - FarfarAway to 010 - Next Major Public Release 1.xxx

Updated by jiaz 11 months ago

  • Status changed from New to Rejected
  • Resolution set to Can't reproduce

Also available in: Atom PDF